What version of the ROAMpay X4 app works with the RP170c Reader?

It is recommended to use the most current version of the ROAMpay X4 app. Please make sure the application is up-to-date with most recent availability.

For additional support, please refer to the Support Page in your merchant portal or contact your ISO contact.